Author Topic: Engine management fuse (15 amp) keeps blowing  (Read 1096 times)

0 Members and 1 Guest are viewing this topic.

Offline Tomspurs

  • Street Triple God
  • *****
  • Posts: 9437
  • 09 ST, CRF230F, DT175MX, DT175C, PE175Z, IT175J
  • Bike: 09 Hinkley ST
  • City / Town: Wallington
  • Country: england
Re: Engine management fuse (15 amp) keeps blowing
Reply #10 on: September 13, 2020, 03:04:04 PM
Clive Wood sometimes gets over to Bristol. His friend Paul (StreetTango) might have some ideas...See Clive on Facebook  :028:
Parc Ferme - Car Park Ross

Offline zappa69

  • Newbie
  • *
  • Topic Author
  • Posts: 7
  • Bike: Street Triple R 2016
  • City / Town: Bristol
  • Country: gb
Re: Engine management fuse (15 amp) keeps blowing
Reply #11 on: September 15, 2020, 09:03:54 PM
*Originally Posted by Tomspurs [+]
Clive Wood sometimes gets over to Bristol. His friend Paul (StreetTango) might have some ideas...See Clive on Facebook  :028:

Do you mean just ask him on Facebook ?? Would he not just tell me to do one ?
Sorry but I don't know who Paul (Street tango ) is ?

Offline street tango

  • Street Triple Master
  • ****
  • Posts: 516
  • The world is orange
  • City / Town: Bristol
Re: Engine management fuse (15 amp) keeps blowing
Reply #12 on: September 23, 2020, 09:41:48 PM
Look on FB 'clive wood triumph'. and ask him or try calling on 07752477738 he wont bite

Offline zappa69

  • Newbie
  • *
  • Topic Author
  • Posts: 7
  • Bike: Street Triple R 2016
  • City / Town: Bristol
  • Country: gb
Re: Engine management fuse (15 amp) keeps blowing
Reply #13 on: September 28, 2020, 08:28:31 PM
*Originally Posted by street tango [+]
Look on FB 'clive wood triumph'. and ask him or try calling on 07752477738 he wont bite

Ok I will do
thanks

 


scandal-fat